Delays in processing new keywords
Incident Report for SEOmonitor
Resolved
The issue has been resolved.
Processing new keywords is now done accordingly.
Posted Feb 13, 2020 - 21:24 EET
Monitoring
A fix has been implemented and we are monitoring it.
Posted Feb 13, 2020 - 20:13 EET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 13, 2020 - 17:10 EET
Investigating
We are currently investigating the issue.
Posted Feb 13, 2020 - 15:53 EET
This incident affected: Visibility Score, Search volumes & keyword aggregation, and New keywords processor.