Delays in processing today’s ranks and Visibility
Incident Report for SEOmonitor
Resolved
We are no longer experiencing any delays and no data has been lost.
Posted May 05, 2020 - 10:38 EEST
Monitoring
All the data is being processed.

We are still monitoring the solution we've implemented.
Posted May 02, 2020 - 10:51 EEST
Identified
The issue has been identified by our tech team.
We are working on solving it.
Posted May 01, 2020 - 13:16 EEST
Investigating
We are currently experiencing delays in processing the ranks and, in turn, calculating the Visibility Scores.
We're investigating the cause and will provide an update as soon as possible.
Posted May 01, 2020 - 10:01 EEST
This incident affected: Rank tracking service and Visibility Score.