Issues in displaying mobile ranks and mobile Visibility Scores on some campaigns
Incident Report for SEOmonitor
Resolved
There have been some slight updates from Google and the way the SERPs look like. We can now read them correctly and there should be no further issues related to these issues.
Posted 9 months ago. Oct 12, 2018 - 17:00 EEST
Investigating
On some campaigns, for the last couple of days, we were experiencing an issue with mobile ranks being mistakenly reported as 99+.
In turn, this also caused a drop to be reported in the Mobile Visibility Scores.

We are currently investigating this and will correct it as soon we have identified the exact cause.
Posted 9 months ago. Oct 08, 2018 - 15:00 EEST
This incident affected: Rank tracking service and Visibility Score.