Delays in processing today’s ranks and Visibility Scores
Incident Report for SEOmonitor
Resolved
The systems are now functioning in normal parameters.
Posted 4 months ago. Dec 21, 2018 - 15:30 EET
Identified
Because of a hardware issue on our rank systems, these will be delayed. The Visibility Scores will also be delayed for the day.
Posted 4 months ago. Dec 21, 2018 - 10:30 EET
This incident affected: Rank tracking service and Visibility Score.