Delays in processing today's ranks and Visibility
Incident Report for SEOmonitor
Resolved
The systems are all functioning at normal speed again. No data has been lost.
Posted Apr 03, 2021 - 11:55 EEST
Monitoring
As a secondary effect of the previous incident we had on ranks, we are experiencing delays in processing today's ranks and Visibility.
Posted Apr 02, 2021 - 08:49 EEST
This incident affected: Rank tracking service and Visibility.