Delays in processing today’s ranks and Visibility Scores
Incident Report for SEOmonitor
Resolved
Delays are no longer to be expected for today's ranks.
Posted 5 months ago. Jan 24, 2019 - 15:30 EET
Monitoring
We're experiencing slight delays in processing today's ranks, but we have already identified the cause and are monitoring the correction we've set in place.
Posted 5 months ago. Jan 24, 2019 - 12:00 EET
This incident affected: Rank tracking service and Visibility Score.