Delays in processing Search Volume data for new campaigns
Incident Report for SEOmonitor
Resolved
The incident has been resolved.

Processing of data is now being done accordingly.
Posted Jan 31, 2020 - 13:30 EET
Monitoring
We're now monitoring the fix that was implemented.
Posted Jan 31, 2020 - 13:06 EET
Investigating
We are currently investigating the issue.
Posted Jan 31, 2020 - 13:04 EET
This incident affected: Visibility Score and Search volumes & keyword aggregation.