Systems down due to connectivity issues between our servers
Incident Report for SEOmonitor
Resolved
The outage has been solved. The cause might have been a network glitch.
Posted Mar 12, 2020 - 12:50 EET
Investigating
We are currently investigating this issue.
Posted Mar 12, 2020 - 12:45 EET
This incident affected: Webapp.