Delays in processing today's ranks and Visibility Scores
Incident Report for SEOmonitor
Resolved
We’re no longer experiencing delays in processing the ranks and Visibility Scores and all of the ones that were pending have been confirmed finalized successfully.
Posted about 1 month ago. Mar 20, 2019 - 11:00 EET
Identified
We’ve determined that it was a hardware problem that caused the ranks (and Visibility Scores) to be delayed. The remaining ones are expected to be done in the following 12 hours.
Posted about 1 month ago. Mar 19, 2019 - 18:00 EET
Investigating
We are currently experiencing delays in processing the daily ranks and, in turn, calculating the Visibility Scores.
We're investigating the cause and will provide an update as soon as possible.
Posted about 1 month ago. Mar 19, 2019 - 15:30 EET
This incident affected: Rank tracking service and Visibility Score.