Delays on today's ranks and Visibility
Incident Report for SEOmonitor
Resolved
The ranks are all back to normal and we've updated our alert systems to take this last issue into account.
Posted Jun 24, 2020 - 21:30 EEST
Identified
We've just confirmed that we have delays with processing today's ranks and Visibility.
Our technical team is working on a fix for this, to bring the speed back to normal.
Posted Jun 24, 2020 - 18:31 EEST
This incident affected: Rank tracking service and Visibility Score.