Delays in processing ranks and Visibility Scores
Incident Report for SEOmonitor
Resolved
After monitoring the current speed for rank and Visibility Score processing, our dev team has confirmed that the update can now be considered successful. The systems are all back to normal, with no data corrupted.
Posted 5 months ago. Mar 07, 2019 - 17:55 EET
Monitoring
The same software upgrade we had performed last week, which generated Friday's delays in processing the ranks and Visibility Scores, was extended and affected last days' speeds as well.

We are still monitoring the incident until we are certain the speeds are fully back to normal.

There was no data loss and no damage, the systems were just slower than usual.
Posted 6 months ago. Mar 06, 2019 - 18:30 EET
Identified
Due to a technical update, there will be slight delays in processing today’s ranks and Visibility Scores.
Posted 6 months ago. Mar 04, 2019 - 11:32 EET
This incident affected: Rank tracking service and Visibility Score.