Delays in processing today’s ranks and Visibility Scores
Incident Report for SEOmonitor
Resolved
The incident has been resolved.
Ranks and Visibility Scores for today are now available.
Posted Oct 16, 2019 - 18:17 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2019 - 18:11 EEST
Identified
The issue has been identified by our tech team and we are working on solving it.
Posted Oct 16, 2019 - 16:11 EEST
Investigating
We are currently experiencing delays in processing the ranks and, in turn, calculating the Visibility Scores.
We're investigating the cause and will provide an update as soon as possible.
Posted Oct 16, 2019 - 16:06 EEST
This incident affected: Rank tracking service and Visibility Score.