Delays on today's ranks and Visibility
Incident Report for SEOmonitor
Resolved
The incident has been resolved.
The current day was locked, but we found the bug causing it and corrected it.
Posted Jul 09, 2020 - 15:08 EEST
Investigating
We are experiencing delays with processing today's ranks and Visibility.
Our tech team is investigating and we will provide updates as soon as possible.
Posted Jul 09, 2020 - 12:10 EEST
This incident affected: Rank tracking service and Visibility Score.