Delays in processing today's ranks (and Visibility Scores)
Incident Report for SEOmonitor
Resolved
The components that had failed have been updated and all systems are now working under normal parameters.
Posted 9 months ago. Nov 07, 2018 - 10:00 EET
Investigating
We are experiencing delays in processing today's ranks and Visibility Scores, because of a partial hardware failure.
Posted 10 months ago. Nov 06, 2018 - 11:30 EET
This incident affected: Rank tracking service and Visibility Score.