Delays in processing today’s ranks and Visibility Scores
Incident Report for SEOmonitor
Resolved
After an update to our systems, the speed of the rank tracking service had significantly decreased. The service is back to normal.
Posted about 2 months ago. Mar 01, 2019 - 15:53 EET
Identified
Due to a technical update, there will be slight delays in processing today’s ranks and Visibility Scores.
Posted about 2 months ago. Feb 28, 2019 - 11:45 EET
This incident affected: Rank tracking service and Visibility Score.