Delays in processing today's ranks on some of the UK market campaigns
Incident Report for SEOmonitor
Resolved
The systems are back to normal, with ranks being processed timely for all markets.
Posted 6 months ago. Oct 11, 2018 - 12:00 EEST
Identified
We are experiencing delays with processing today's desktop ranks on some of the campaigns on the UK market. We've identified potential causes, but the system is not yet working at full capacity.
Posted 6 months ago. Oct 10, 2018 - 13:15 EEST
This incident affected: Rank tracking service and Visibility Score.