Delays in processing today’s ranks and Visibility
Incident Report for SEOmonitor
Resolved
Today's ranks and Visibility are now available. The incident had been resolved.
Posted Mar 24, 2020 - 10:00 EET
Monitoring
We're monitoring the results for the fix we've implemented.
Posted Mar 21, 2020 - 09:22 EET
Identified
The issue has been identified by our tech team.
We are working on solving it.
Posted Mar 20, 2020 - 17:16 EET
Investigating
We are currently experiencing delays in processing the ranks and, in turn, calculating the Visibility Scores.
We're investigating the cause and will provide an update as soon as possible.
Posted Mar 20, 2020 - 15:48 EET
This incident affected: Rank tracking service and Visibility Score.