Delays in processing today’s ranks and Visibility
Incident Report for SEOmonitor
Resolved
Today's ranks and Visibility are now available. The incident had been resolved.
Posted Mar 03, 2020 - 14:50 EET
Monitoring
We've implemented a fix and we're monitoring the result.
Posted Mar 03, 2020 - 14:20 EET
Identified
The issue has been identified by our tech team.
We are working on solving it.
Posted Mar 03, 2020 - 11:10 EET
Update
We are continuing to investigate this issue.
Posted Mar 03, 2020 - 10:40 EET
Investigating
We are currently experiencing delays in processing the ranks and, in turn, calculating the Visibility Scores.
We're investigating the cause and will provide an update as soon as possible.
Posted Mar 03, 2020 - 10:40 EET
This incident affected: Rank tracking service and Visibility Score.