Delays in processing today's ranks
Incident Report for SEOmonitor
Resolved
Processing of the data has finished. All systems functions are back to normal.
Posted Sep 07, 2019 - 17:56 EEST
Monitoring
The technical team has identified a malfunction at one of the database servers which caused delays in processing today's ranks and analytics data.

A fix has been implemented and we are already processing the data that will be available soon.
Posted Sep 07, 2019 - 10:00 EEST
This incident affected: Visibility Score and Traffic segmentation service.