Delays in processing today’s ranks and traffic
Incident Report for SEOmonitor
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 12, 2019 - 14:26 EEST
Monitoring
The issue has been found and fixed and we are now processing all the data.
Posted 3 months ago. Jul 12, 2019 - 11:30 EEST
Investigating
We are currently experiencing delays in processing the ranks and daily traffic and, in turn, calculating the Visibility Scores.
We're investigating the cause and will provide an update as soon as possible.
Posted 3 months ago. Jul 12, 2019 - 08:27 EEST
This incident affected: Rank tracking service, Visibility Score, and Traffic segmentation service.