Delays in processing today's Ranks and Visibility Scores
Incident Report for SEOmonitor
Resolved
Our tech team has identified and monitored the erroneous behaviour on our hardware sytems. We can now consider it resolved and all ranks and Visibility Scores up to date.
Posted 10 months ago. Aug 28, 2018 - 17:50 EEST
Identified
Due to an overnight hardware problem, we are experiencing delays in processing and displaying some of today's ranks and Visibility Scores.
Posted 10 months ago. Aug 28, 2018 - 13:45 EEST
This incident affected: Rank tracking service and Visibility Score.