Issues logging into the platform
Incident Report for SEOmonitor
Resolved
The incident has been resolved by our tech team.
There are no longer problems with logging into the platform.
Posted Sep 26, 2019 - 13:58 EEST
Update
We are continuing to investigate this issue.
Posted Sep 26, 2019 - 13:56 EEST
Investigating
Some users are experiencing issues logging into the platform.
We are currently investigating the issue.
Posted Sep 26, 2019 - 13:55 EEST
This incident affected: Webapp.