Delays in processing ranks and Visibility Scores
Incident Report for SEOmonitor
Resolved
We found that there have been some hardware components partially affected as well. The tech team has performed corrective actions and we are no longer expecting delays in the daily rank (and Visibility Score) processing.
Posted 10 months ago. Sep 04, 2018 - 14:00 EEST
Update
The tech team is working on deploying some new components, that would restabilize the systems.
Posted 10 months ago. Aug 31, 2018 - 10:30 EEST
Identified
Because of a Google update, some campaigns are experiencing delays in showing today's ranks and, in turn, Visibility Scores.
Posted 10 months ago. Aug 30, 2018 - 12:30 EEST
This incident affected: Rank tracking service and Visibility Score.