Delays for the weekend ranks and Visibility Scores
Incident Report for SEOmonitor
Resolved
We are no longer experiencing delays with today's ranks. All ranks from the weekend have been processed.
The same goes for the Visibility.
Posted May 25, 2020 - 19:23 EEST
Identified
We have identified that there was an issue with our database servers, so we could not process the weekend ranks in time.
No ranks have been lost and we will process and show them accordingly over the following hours.
Posted May 25, 2020 - 10:00 EEST
This incident affected: Rank tracking service and Visibility Score.