Delays in processing today’s ranks and Visibility
Incident Report for SEOmonitor
Resolved
Today's ranks and Visibility are now available. The incident had been resolved.
Posted Apr 15, 2020 - 10:26 EEST
Update
We're monitoring the results for the fix we've implemented.
Posted Apr 14, 2020 - 19:43 EEST
Identified
The issue has been identified by our tech team.
We are working on solving it.
Posted Apr 14, 2020 - 16:12 EEST
Investigating
We are currently experiencing delays in processing the ranks and, in turn, calculating the Visibility Scores.
We're investigating the cause and will provide an update as soon as possible.
Posted Apr 14, 2020 - 10:06 EEST
This incident affected: Rank tracking service and Visibility Score.