Delays in ranks and Visibility Scores for today
Incident Report for SEOmonitor
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 26, 2019 - 15:58 EEST
Identified
As a consequence of yesterday’s scheduled maintenance, we’re currently experiencing delays in processing today’s ranks and Visibility Scores. Our tech team is investigating the issue at the moment.
Posted 4 months ago. Jun 26, 2019 - 11:47 EEST
This incident affected: Rank tracking service and Visibility Score.