Delays in ranks and Visibility Scores for today
Incident Report for SEOmonitor
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 01, 2019 - 21:37 EEST
Update
-
Posted 5 months ago. Jun 01, 2019 - 21:36 EEST
Monitoring
A fix has been implemented and the rank tracking service is back at normal speed.
Posted 5 months ago. Jun 01, 2019 - 21:36 EEST
Investigating
We’re currently experiencing delays in processing today's ranks. Our tech team is investigating the issue at the moment.
Posted 5 months ago. May 31, 2019 - 12:18 EEST
This incident affected: Rank tracking service and Visibility Score.