Delays in processing today’s ranks and Visibility Scores
Incident Report for SEOmonitor
Resolved
There were some minor infrastructure issues which have now been solved.
No data has been compromised and is now fully available.
Posted Aug 13, 2019 - 17:49 EEST
Investigating
We are currently experiencing delays in processing the ranks and, in turn, calculating the Visibility Scores.
We're investigating the cause and will provide an update as soon as possible.
Posted Aug 13, 2019 - 14:00 EEST
This incident affected: Rank tracking service and Visibility Score.