Incomplete Competition Rank Data
Incident Report for SEOmonitor
Resolved
Everything is up and running, the issue has been solved.
Posted Aug 06, 2019 - 18:49 EEST
Identified
We acknowledged that the competitors’ mobile data from the Competition section are incomplete.
The fix is in progress.
Posted Aug 06, 2019 - 14:44 EEST
This incident affected: Rank tracking service.