Delays in processing today’s ranks and Visibility
Incident Report for SEOmonitor
Resolved
Today's ranks and Visibility are now available. The incident had been resolved.
Posted Mar 06, 2020 - 16:26 EET
Update
All the data is being processed.

We are still monitoring the solution we've implemented.
Posted Mar 06, 2020 - 12:13 EET
Monitoring
We're still monitoring the fix.
Posted Mar 05, 2020 - 12:57 EET
Investigating
The fix for yesterday's incident is still being monitored.

There still are some campaigns for which we are currently experiencing delays in processing the ranks and, in turn, calculating the Visibility Scores.
We're investigating the cause and will provide an update as soon as possible.
Posted Mar 05, 2020 - 08:45 EET
This incident affected: Rank tracking service and Visibility Score.