Delays in processing new campaigns and keywords
Incident Report for SEOmonitor
Resolved
All systems are back to normal processing speed. No data has been lost.
Posted Jul 28, 2021 - 11:03 EEST
Identified
We are experiencing issues with one of our rank processing queues, so there will be delays with the new campaign and keyword processing (ranks and Visibility).
Posted Jul 27, 2021 - 18:35 EEST
This incident affected: Rank tracking service, Visibility, and New keyword processor.