Delays in processing today's ranks and Visibility
Incident Report for SEOmonitor
Resolved
The systems are back to normal functioning speed and all data is now processed.
Posted May 14, 2021 - 12:23 EEST
Identified
We have identified that an update identified yesterday has been causing our rank queues to be slowed down.
Posted May 14, 2021 - 06:00 EEST
This incident affected: Rank tracking service and Visibility.