Downtime accross the entire platform

Incident Report for SEOmonitor

Resolved

This incident has been resolved.
The platform is fully operational, and no data was lost.
Posted Nov 19, 2025 - 12:44 EET

Monitoring

We identified and implemented a solution, and we're currently monitoring to ensure there are no further issues.
Posted Nov 18, 2025 - 17:05 EET

Identified

We are experiencing downtime, causing E500 errors while using the platform, due to an ongoing issue affecting our third-party provider Cloudflare.
Posted Nov 18, 2025 - 14:09 EET
This incident affected: Core Platform.