Delays in processing new campaigns and keywords
Incident Report for SEOmonitor
Resolved
The issue has been solved, and all systems are back to normal operating speed. No data has been lost.
Posted Jul 31, 2024 - 13:40 EEST
Investigating
We are investigating an issue on one of our servers, that is causing delays in processing data for new campaigns and keywords.
Posted Jul 30, 2024 - 21:49 EEST
This incident affected: Daily Keyword Tracker and Keyword Import Processor.