Issues with the Research section
Incident Report for SEOmonitor
Resolved
The incident has been resolved, and all systems are back to normal. No data has been lost.
Posted Dec 19, 2024 - 00:43 EET
Identified
We identified an issue affecting the platform's Research section and are working on a fix.
This will cause delays in the monthly update of the existing data and delays or downtime on new keyword processing.
The existing data remains accessible.
Posted Dec 18, 2024 - 21:10 EET
This incident affected: Research Tools.