Slow loading times (or downtime) in the Domain Explorer (Research)
Incident Report for SEOmonitor
Resolved
The issue was fixed, and all systems are back to normal. No data was affected.
Posted Aug 13, 2024 - 15:02 EEST
Identified
We have identified an issue causing delays (or downtime) in the Domain Explorer, in the Research tools.
Posted Aug 13, 2024 - 14:37 EEST
This incident affected: Research Tools.