Issues with Website Explorer and intermittent issues with Research keyword processing
Incident Report for SEOmonitor
Resolved
The incident has been resolved, and all systems are back to normal. No data has been lost.
Posted Dec 18, 2024 - 15:15 EET
Investigating
We are investigating issues with the Website Explorer and some of the Research keyword processing.

Keyword Explorer and Keyword Lists (Vault) are operating in normal parameters.
Posted Dec 18, 2024 - 13:19 EET
This incident affected: Research Tools.