Maintenance followup on US Research tools

Incident Report for SEOmonitor

Resolved

The maintenance work has been completed successfully.
Posted Sep 05, 2024 - 10:54 EEST

Monitoring

We have to follow up on yesterday's maintenance, with an update on our US servers.

The Research tools (Website Explorer, Keyword Explorer, Keyword Vault) for the US market alone will be impacted.
Posted Sep 05, 2024 - 10:00 EEST
This incident affected: Research Tools.