Delays in processing new keywords and campaigns

Incident Report for SEOmonitor

Identified

We're working on an improved solution. The systems are back to delayed processing speed for new campaigns and keywords.
Posted Sep 17, 2025 - 17:28 EEST

Monitoring

A fix has been implemented, and we're back to normal processing speed.
We are continuing to monitor the results for another hour.
Posted Sep 17, 2025 - 16:24 EEST

Identified

We're experiencing delays in processing new keywords and campaigns due to the crawling challenges caused by the recent removal of the Google page depth (&num=100) parameter.
We're working on implementing a more efficient solution.
Posted Sep 17, 2025 - 10:24 EEST
This incident affects: Daily Keyword Tracker and Keyword Import Processor.