Delays in processing payments and slow loading times

Incident Report for SEOmonitor

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 11:28 EEST

Identified

We're experiencing delays in processing payments slow loading times on various pages as a consequence of some of our third-party providers being impacted by the Amazon Web Service outage.
Posted Oct 20, 2025 - 06:00 EEST
This incident affected: Core Platform.