Slow processing of new keywords and campaigns

Incident Report for SEOmonitor

Resolved

The incident has been resolved. All systems are back to normal.
Posted Jun 03, 2025 - 22:03 EEST

Identified

We have identified an issue causing delays in processing new keywords and campaigns that's primarily affecting resources tracked for the UK market.
Posted Jun 03, 2025 - 19:01 EEST
This incident affected: Keyword Import Processor.