Competition section issues

Incident Report for SEOmonitor

Monitoring

A partial fix has been implemented, and we are monitoring the results for another 2 hours.
We are now only expecting issues with sorting the data in the Competition module.
Posted Sep 17, 2025 - 16:26 EEST

Identified

We identified an issue causing the malfunctioning of the Competition section.
While we're working on the fix, the section will be fully or partially inaccessible.
Posted Sep 17, 2025 - 10:11 EEST
This incident affects: Core Platform.