Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 20, 2026 - 10:45 EEST
Scheduled
We will be undergoing maintenance on all our databases, and we expect intermittent downtime during the scheduled timeframe. Adding/updating data is expected to be unavailable during this time.
Posted May 20, 2026 - 10:41 EEST
This scheduled maintenance affected: Core Platform.