Intermittent downtime and delays
Incident Report for SEOmonitor
Resolved
We have identified the bug (on the Organic Traffic and the previous Rank Tracker) and fixed it. No other issues are expected and no data has been lost.
Posted Nov 19, 2021 - 15:44 EET
Investigating
We are experiencing intermittent downtime on some accounts. E500 errors and delays are expected.
Posted Nov 19, 2021 - 14:00 EET
This incident affected: Webapp.