Slow loading times (or downtime) across the platform
Incident Report for SEOmonitor
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 11:11 EET
Investigating
We have identified an issue causing slow loading times (or downtime) across the platform.
We're currently investigating the cause.
Posted Mar 13, 2024 - 10:42 EET
This incident affected: Webapp.