Slow processing of new keywords and campaigns

Incident Report for SEOmonitor

Resolved

The incident has been resolved. All systems are back to normal. No data has been lost.
Posted Mar 07, 2025 - 21:14 EET

Monitoring

A fix has been implemented, and we are monitoring the results.
There was a change on Google's side in the mobile SERP navigation.
Posted Mar 07, 2025 - 15:10 EET

Identified

We have identified an issue with one of our service providers, causing slow processing of new keywords and campaigns.
Posted Mar 06, 2025 - 14:49 EET
This incident affected: Keyword Import Processor.