Delays in processing new campaigns and keywords
Incident Report for SEOmonitor
Resolved
The incident has been resolved. All systems are back to normal and no data has been lost.
Posted May 13, 2021 - 19:15 EEST
Investigating
We are experiencing delays in processing new campaigns and keywords.
Posted May 13, 2021 - 15:51 EEST
This incident affected: New keyword processor.