Downtime on the US database

Incident Report for SEOmonitor

Resolved

The isuue has been resolved. All systems are back to normal.
Posted Jun 10, 2025 - 10:35 EEST

Identified

We're experiencing a hardware problem causing downtime on the US database.
This impacts the Research tools on it - Keyword/Topic Explorer, Website Explorer, Vault/Lists.
Posted Jun 07, 2025 - 20:44 EEST
This incident affected: Research Tools.