All blocked imports have been automatically processed.
Posted Feb 19, 2025 - 19:26 EET
Monitoring
We have implemented a fix and are monitoring the results. The imports are now unblocked and will be automatically processed, so there's no need to redo them.
Posted Feb 18, 2025 - 22:50 EET
Investigating
We are investigating an issue causing delays with keyword imports in the Rank Tracker.