Secondary Device Rank Processing Delay

Incident Report for SEOmonitor

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 16:18 EEST

Identified

We identified an issue causing delays in processing new ranks for the secondary device.
We're currently working on the fix.
Posted Apr 16, 2026 - 11:36 EEST
This incident affected: Daily Keyword Tracker and AI Content Writer.